In order to protect your data, effective from September 15th 2018 the Agility product stopped supporting browser versions which use SSL V3.0 or TLS V1.0, which have known vulnerabilities. 

Further, effective from January 31st 2019 our Agility products will only support TLS version 1.2 or higher.

To make sure this will not affect you, please see a list of minimum browser versions and their release dates below:

Chrome 30 (October, 2013)
Internet Explorer 11 (October, 2013)
Edge - All versions supported
Firefox 27 (September, 2013)
Safari 7 (October, 2013)

You will not be able to connect to Agility if your browser is using TLS 1.0 or lower. Instructions on how to change the version of TLS used by the browser is described at the link below:

https://knowledge.digicert.com/generalinformation/INFO3299.html

We are here to help at agilitysupport@agilitypr.com

Did this answer your question?